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rial and workmanship for a period of one 
year from date of shipment. During the 
warranty period, Agilent will, at its option, 
either repair or replace products that prove 
to be defective.

For warranty service or repair, this product 
must be returned to a service facility desig-
nated by Agilent. Buyer shall prepay ship-
ping charges to Agilent and Agilent shall 
pay shipping charges to return the product 
to Buyer. However, Buyer shall pay all ship-
ping charges, duties, and taxes for prod-
ucts returned to Agilent from another 
country.

Agilent warrants that its software and 
firmware designated by Agilent for use 
with an instrument will execute its pro-
gramming instructions when properly 
installed on that instrument. Agilent does 
not warrant that the operation of the 
instrument, software, or firmware will be 
uninterrupted or error free. 

Limitation of Warranty
The foregoing warranty shall not apply to 
defects resulting from improper or inade-
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Certification
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Introduction

DTS Configurator provides an easy-to-use graphical user interface to the 
DTS instrument and can be used as the basic application for handling 
configurations and traces. 

It enables calibrating the sensor, creating configurations, creating 
measurement sequences, starting measurements, and saving and viewing 
traces.

N O T E Some features (creating/modifying schedules, running scheduled measurements) will be 
implemented in later releases. In the current version, these features are disabled or inactive.

N O T E This guide assumes you are already familiar with your instrument’s operation and parameters. For 
details on the DTS instrument refer to Agilent N4385A/N4386A Distributed Temperature System 
User’s Guide.
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Installation

Requirements
DTS Configurator runs on Windows 2000/XP operating systems. 
Windows 95, ME, and NT operating systems are not supported.

Software requirements:
• Microsoft .NET Framework version 1.1
• Agilent IO Libraries Suite 

Agilent IO Libraries Suite is needed for communication with the DTS 
device. It is downloadable from http://www.agilent.com/find/iosuite

Hardware requirements:
• Pentium III, 700 MHz CPU
• 256 MB RAM
• 15 MB free disk space
• Ethernet or USB (refer to Agilent N4385A/N4386A Distributed 

Temperature System User's Guide).

Installing DTS Configurator
To install the DTS Configurator, insert the installation CD into your CD-
ROM drive and run setup.exe.

The installation wizard will guide you through the installation procedure. 
Read the license agreement carefully before agreeing and then follow the 
wizard to select the destination folder and complete the installation.

N O T E After installation, there are no predefined users and the application will work in the anonymous 
mode (no authentication is required). For instructions on how to add users, refer to chapter “Users” 
on page 43.

http://adn.tm.agilent.com/index.cgi?CONTENT_ID=70713
http://adn.tm.agilent.com/index.cgi?CONTENT_ID=70713
http://adn.tm.agilent.com/index.cgi?CONTENT_ID=70713


Getting Started

4 DTS Configurator, Second edition, April 2007

User Interface

DTS Configurator is a standard Windows based application. It works as 
any common Windows application with menus, toolbars, navigation and 
visualization.

When you start the application the window for instrument discovery 
opens first, where you need to perform instrument discovery (see “DTS 
Instrument Discovery” on page 15).

The application window is divided into four main areas. On the left are the 
File Explorer pane (above) and the Properties pane (below). On the right 
side is the Data Visualization pane. The bottom part of the window 
contains the Instrument pane. Refer to Figure 1 on page 4.

All described areas can be resized, moved, and customized. To move a 
pane, double-click its title bar and the pane will detach from the window 
and you can move it to a place of your choice. To put the pane into its 
original position double-click its title bar again.

To select which panes you want to view open the View menu and select 
the panes you want to view.

Figure 1 Graphical User Interface
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File Explorer Pane
File Explorer pane contains the list of configurations, sequences, and 
trace files. 

Naming of entries
• Each new entry is marked with * until saved. 
• When an entry is saved it receives ..\ prefix.
• When a saved entry is modified it receives * next to the name until it is 

saved again.

Editing options are available in the context menu for each list entry. To 
access the context menu, right-click an entry.

Configuration context menu contains:
• Edit; opens the Configuration Editor dialog box. For more information 

see chapter “Configurations” on page 21.
• Clone; creates a clone of the selected configuration. The name of the 

clone is marked with C and the number of clone, created for the 
selected configuration, e.g. C1-configuration_name.

Sequence context menu contains:
• Edit; opens the Sequence Editor dialog box. For more information see 

chapter “Sequences” on page 31.
• Clone; creates a clone of the selected sequence. The name of the 

clone is marked with C and the number of clone, created for the 
selected sequence, e.g. C1-sequence_name.

Sequence/Configuration context menu contains:
• Edit; opens the Configuration Editor dialog box. For more information 

see chapter “Configurations” on page 21.
• Remove; removes the selected configuration from the sequence.

Trace context menu contains:
• Visible; if ticked, the trace is visible in the Data Visualization pane.
• Markers; if ticked, the markers are visible in the Data Visualization 

pane
• Show graph; opens the graph of the selected trace in the Data 

Visualization pane.
• Extract Configuration; extracts the configuration from the trace file 

and displays it in the list of configurations.
• Clone; creates a clone of the selected trace. The name of the clone is 

marked with C and the number of clone, created for the selected trace, 
e.g. C1-trace_name.
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Figure 2 File Explorer Pane

Properties Pane
Properties pane displays information about markers, measurements and 
sensors. 
• General section displays general data of the selected trace file, e.g. 

trace alias and name of the configuration file.
• Measurement section displays measurement data for the selected 

configuration or for the configuration of the selected trace.
• Sensor section displays sensor information and sections information 

for the selected configuration or for the configuration of the selected 
trace. To view section information select the section entry and click the 
button next to it.

• Alarms section displays data about alarm settings in the selected trace 
file. To view zones or fire classes information select the Zones or Fire 
Classes entry and click the button next to it.
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Figure 3 Properties Pane

Data Visualization Pane
Data Visualization pane displays a chart with measurement values for the 
selected configuration or for the configuration of the selected trace. The 
visualization pane is named after the trace of the measurement that is 
currently in progress. Markers are displayed only when a trace is selected 
and if the markers are ticked in the context menu of the trace.

You can zoom in on a part of the chart by clicking and dragging the mouse 
over the area you want to magnify.

Editing options are available in the context menu. To access the context 
menu, right-click the chart. The menu contains the following actions: 
AutoScale, Zoom, Undo Zoom, Print, Copy, Save, and Properties.

Select Temp, Loss, Alarm, and/or Zone to track selected data and display 
any of the selected status panes.
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Figure 4 Data Visualization Pane

Loss Status Pane

Loss Status pane displays information about losses occurred during the 
measurement process.

Alarm and Zone Status Panes

Alarm and Zone Status panes display information about fires, raised 
alarms and zones in which the fires occurred.

N O T E Alarm and Zone Status panes are available only when alarm handling for selected configuration is 
enabled.

In the Alarms list the five biggest fires that occurred in the selected 
configuration are listed. For the biggest fire the direction of the fire is also 
given.

Zone Status list displays either all zones or only zones with alarms (if only 
Zones with Alarm is checked). Zones and parameters are coded with 
colors:
• red in case the parameter raised a new alarm,
• yellow in case the parameter raised an alarm since the last reset but is 

currently without a raised alarm,
• orange in case of a fiber break in this or any previous zone (data is 

unavailable),
• white if none of the parameters raised an alarm.
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Figure 5 Alarm and Zone Status Pane

Instrument Pane
Instrument pane displays information about the active instrument, active 
outputs, and fiber breaks. 
• Instrument section displays data about the active instrument (e.g. 

default instrument, connection type, instrument status, number of 
measurements during the measurement process) and connection 
status. If connection fails the instrument handles the device 
connection automatically.

N O T E The next sections are available only when alarm handling for selected configuration is enabled, 
otherwise the More button is disabled.

• Active Outputs section displays list of outputs. Outputs marked with 
orange color have been activated since the last alarm reset.

• Fiber Breaks section displays information if fiber breaks occurred on a 
sensor or not.

• Reset Alarms button clears all alarms from all zones.

Figure 6 Instrument Pane

Menu Bar
The Menu Bar provides mouse driven access to many high level functions 
related to DTS measurements, along with administrative functions, 
application settings and help.

Menu Bar contains the following menus:
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• File - Standard Windows file operations (Open, Save, Close...) and 
application exit.

• Edit - Access to configuration, sequence, schedule, and trace settings.
• View - Used for selecting toolbars, for opening File Explorer, 

Properties, and Instrument panes, for opening graph comparison of 
temperatures and losses, and for centering markers.

• Instrument - Instrument settings, instrument discovery, starting and 
stopping of measurement for the selected configuration or sequence, 
access to downloading of configurations and traces, access to the log 
file.

• Settings - User management (login/logout), language settings, and 
application settings.

• Window - Four basic types of window arrangement. Useful when 
viewing more than one measurement trace graph.

• Help - Application Help and information.

Tool Bar
The Tool Bar consists of three option groups and offers shortcuts to 
operations mentioned in the Menu Bar chapter:
• File Menu Actions - Create New, Open, Save, and Close.
• Measurement Menu Actions - Start Measurement, Stop 

Measurement, and DTS Discovery.
• Settings Menu Actions - Login, Options, Show Help, and Center 

Markers.
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Application Settings

You can customize the DTS Configurator settings. To change application 
settings, select Options in the Settings menu. The Program Options dialog 
box opens, where you can set or change the settings.

General Application Settings
Select Applications where you can set the general application settings. 
Refer to Table 1 on page 11.

Units

You can set the view to US customary units or metric units. Select 
temperature and distance units that will be used throughout the interface: 
meters or feet and degrees Celsius or Fahrenheit.

Select the axis on which you would like the data to display in graphs. If 
you select the X axis the graph will be displayed along the X axis. If you 
select the Y axis, the graph will be displayed along the Y axis.

Traces Settings
Select Traces where you can set the trace settings. Refer to Table 2 on 
page 12.

Table 1 Application Settings

Option Description

Show login on app. start This option controls whether the Login dialog 
box opens when the application is started. You 
can set the time interval after which it 
automatically closes.

Ask before rebooting 
instrument

This option controls whether the warning before 
instrument reboot appears or not (in Instrument 
Properties window, under Settings, 
Instrument).

Open configuration edit 
dialog on new configuration

Default text editor This option enables you to set the default text 
editor for viewing log files.

Default folder This option enables you to select the default 
destination folder for all configuration, schedule, 
and trace files.

Layout This option saves you application layout settings.
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Users Settings
For instructions on how to set the user settings, refer to chapter “Users” 
on page 43.

Table 2 Traces Settings

Option Description

Save multiple traces in 
single file

This option enables you to save multiple traces 
in a single trace file. If the option is not selected, 
each trace will be saved in a separate file.

Hide invalid values This option enables you to hide the invalid 
temperature/loss values, like the ones when 
fiber break occurs (temperatures of -273.15°C 
and loss of -80 dB).

Auto Save Enable or disable autosave. All trace files will be 
stored into the specified folder with the filename 
prefix which is a combination of the 
configuration name and a prefix defined in the 
Filename prefix setting.

NOTE:

Depending on the measurement settings, 
enabling AutoSave may consume a large portion 
of disk space.

Enabling AutoSave option together with Save 
multiple traces in single file option, could result 
in very large trace files and could slow down the 
application.

Memory Free memory space for saving files can span 
from 30 to 100 MB. If less than required is 
available, the traces will not be saved. 

Memory/Maximum number 
of traces in memory

Maximum number of traces in the application.

Memory/Maximum number 
of stored traces per 
measurement

Traces above the defined number will be handled 
according to the selected handling of excess 
traces.

Show warning when... Enable or disable warning notification.
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Introduction

DTS Configurator enables management of measurement configurations 
and reviewing measurement traces.

In addition, it provides a user interface to the connected DTS instruments. 
You can set instrument specific data, calibrate the sensor, start and stop 
measurements, save results (traces), and manage connected instrument.

N O T E Some actions require user authentication and you should log in to be able to perform them (for 
example, starting, stopping measurements, configuring the DTS instrument). For more information 
about user authentication, refer to chapter “Users” on page 43.

File Management
DTS Configurator provides a common file management system for 
managing configurations, sequences, and traces. You can add new files, 
open existing ones and modify them, copy them and save them. 

You can also open multiple files and close them one by one (using the 
Close option in the File menu) or all at once (using the Close All option in 
the File menu).

The same principle applies for saving the files. You can use the Save 
option in the File menu to save the currently selected file, or Save All to 
save all open files.

N O T E The destination folder for new and copied files is defined under the Settings -> Options menu in 
the Program Options dialog box under Application -> Default Folder.
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DTS Instrument

Managing the DTS instrument involves the following:
• performing DTS instrument discovery 

Refer to chapter “DTS Instrument Discovery” on page 15.
• calibrating the instrument sensor 

Refer to chapter “Calibrating Instrument Sensor” on page 17.

DTS Instrument Discovery
N O T E If user authorization mode is set, you must be logged in before you can find and add an instrument.

DTS Configurator enables you to find and add available DTS instruments. 
You can also connect to the global VISA database, which contains the 
instruments previously discovered using the Agilent Connection Expert.

N O T E The application retains information on all discovered instruments, but connects to only one 
instrument at a time.

To perform DTS instrument discovery, follow the procedure below:
1 In the Instrument menu click Discovery. The DTS dialog box opens.
2 You can find an instrument in two ways:

• Click Quick Find to list all instruments, which were already 
discovered by Agilent Connection Expert. Instruments are listed in 
a tree. Each instrument can have up to 4 different entries, one for 
each type of connection.

Figure 7 DTS Instrument Discovery - Quick Find
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• Click Find DTS to search for a new instrument. The Find DTS dialog 
box opens, where you can search for the instrument by hostname, 
IP address, or VISA address. Select the appropriate option and 
enter required information. When searching by hostname or IP 
address, you can also specify advanced search options.

Figure 8 Finding Specific Instrument

3 Set the default instrument and click OK.

A user can remove an instrument by selecting it and clicking the Remove 
button. If the removed instrument was set as default instrument, the user 
must select another default instrument.

An instrument can be connected in more than one way (e.g. via LAN and 
USB). Such instrument is listed twice in the list of instruments. The two 
insertions can be differentiated by the data in the VISA address column.

Instrument Properties
N O T E If user authorization mode is set, you must be logged in before you can modify the instrument 

properties.

To open the Instrument Properties window, go to Instrument and 
Discovery. In the DTS window select the instrument and click Properties 
button. In this window you can:
• set general instrument data (General)
• set communication between instrument host and network domain 

(Communication)
• test inputs and outputs (Electrical In/Out)
• set number of traces before the alarm or select Restart Measurement 

automatically after Power On (Misc)
• restart the network or reboot the instrument.
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Figure 9 Instrument properties

Changed properties can be saved by clicking the Apply button.

Calibrating Instrument Sensor
Sensor calibration data is part of a configuration and can be obtained 
using the Sensor Calibration Wizard. The Wizard guides you through the 
steps of the calibration procedure and helps you determine the sensor 
calibration values (gain, offset and linearity).

To calibrate the sensor perform the following steps:
1 From the File Explorer pane select a configuration and right-click it.
2 Click Edit and in the Configuration Editor window select Sensor.
3 Click Calibration Wizard button to open the wizard. On the first page 

all steps that follow are listed.

Figure 10 Sensor Calibration Wizard
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4 On the Selecting Data Source page of the wizard, you can select one of 
the following options:
• Two reference regions per section 

You can run one measurement with two reference regions (known 
temperature-points) per sensor section. In this case select either 
run a measurement or open trace file.

• One reference region per section 
In this case select two trace files.

N O T E Loaded measurement is rejected in case it holds at least two sections with different attenuation 
ratio. User is prompted with an error message.

N O T E Configurations included in the sequence and marked as dual-ended can only be calibrated with dual 
ended traces or with a new measurement from the sensor calibration wizard. Otherwise calibrations 
can be performed only with single-ended traces.

Click Next to continue.
Figure 11 Selecting Data Source

5 According to the previous selection there are two possibilities:
• If you selected run a measurement you need to define 

measurement time and click Start. The measurement will start.
• If you selected one or two trace files the traces are displayed in the 

Confirm Selected Traces window. Click Next to continue.
6 In the Set end of fiber section or finish calibration window do one or all 

of the following steps in the same order as described below:
• Move the cursor to select the end of the first fiber section or
• Click Set length button to correct the refractive index, set accurate 

length, or set the scaling factor. Confirm with Enter and click Next.
N O T E To move between Set Refractive Index and Set Section End fields use Back and Next buttons.
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• Click Set Temp to choose calibration type and to set the 
attenuation ratio, temperature gain, and temperature offset. 

• In the Choose Calibration Type window the Gain and Offset 
Calibration is already selected if you selected two trace files in Step 
1 window. If you selected only one trace file, you can choose 
between Gain and Offset Calibration and only Offset Calibration. 
Click Next.

• The selected section is displayed in the Set Attenuation Ratio 
window. With black cursors select region 1, with green cursors 
select region 2. To calculate the attenuation ratio select which 
region to include and click Calculate and Next.

N O T E You can insert the attenuation ratio manually.

• On the Set the Actual Temperature page click Calculate to get the 
measured temperatures and then insert the actual temperatures 
that occur in the selected regions. Click Next to get Gain, Offset 
and Attenuation ratio results and click Next to confirm.

• Once a fiber section is added you can finish calibration by clicking 
the Finish button, create a new sensor section by clicking the Add 
button or change the data of the last section. You can add and 
calibrate up to 16 sections.

N O T E You can change only the last calibration section in order to keep section junctures untouched. To 
change the first section you must delete all the following sections first.

Figure 12 Set end of fiber section or finish calibration

7 When you click Finish, the changes are saved into the configuration 
for which you created the calibration. The changes are visible in the 
Configuration dialog box (Edit -> Configuration -> Sensor).



Using DTS Configurator

20 DTS Configurator, Second edition, April 2007

Log File
Log file contains information about all actions that happened on an 
instrument. 

To view the log file select Log File in the Instrument menu. A new window 
with contents of the log file will open.

N O T E If you already have a log file open and you open another log file from the Instrument menu, the old 
log file will close and the new will open.
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Configurations

Managing measurement configurations involves the following:
• creating new configurations 

Refer to chapter “Creating a New Configuration” on page 21.
• modifying existing configurations 

Refer to chapter “Modifying a Configuration” on page 28.
• copying existing configurations 

Refer to chapter “Copying a Configuration” on page 28.
• extracting configuration from trace file 

Refer to chapter “Extracting a Configuration from a Trace” on page 28.

Creating a New Configuration
To create a new configuration, follow the procedure below:
1 In the File menu click New and select Configuration. A new 

configuration item is added in the File Explorer.
2 Select the new configuration and then in the Edit menu click 

Configuration. The Configuration Editor dialog box opens. The window 
opens also if you double-click the configuration or right-click it and 
select Edit.

3 Select Measurement and specify the required settings. Refer to Table 3 
on page 21.

Table 3 The Configuration Measurement Settings

Option Description

File Name Name of the configuration file

Channel Number of the channel

Alias Name of the channel (up to 79 
characters)

Comment Additional description or comments (up 
to 79 characters)

Start Start distance of measurement results

Span End distance of measurement results

Time (s) Duration of the measurement in 
seconds

Update Time (s) The intermediate trace update time in 
seconds

Sampling Interval The distance between samples in the 
measurement result trace.
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N O T E Channel Number and Channel Alias are used only for systems with optical switch.  
For additional information on different options, refer to Agilent N4385A/N4386A Distributed 
Temperature System User’s Guide.

Figure 13 Configuration Measurement Settings

4 Select Sensor and specify the settings as required. Refer to Table 4 on 
page 22.

Spatial Resolution Spatial resolution setting for the 
instrument

Data Saved The sort of data to collect

Repeat Setting for repeating the measurement

Repeat Value Number of measurement repetitions

Table 3 The Configuration Measurement Settings

Option Description

Table 4 Configuration Sensor Settings

Option Description

Start Point Offset The distance from the measured 
material

Temperature Offset The temperature offset from the 
measured material

Sensor Sections Sensor calibration sections as 
determined in the calibration process. 
You can edit section settings manually 
by double-clicking the entry in the 
Temperature Calibration Data list.
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Figure 14 Configuration Sensor Settings

5 To modify the section settings, double-click the entry in the list. The 
Sensor Section dialog box opens, where you can specify the section 
options as required. Refer to Table 5 on page 23.

Table 5 Section Settings

Option Description

Span The length of the section

Refractive Index The refractive index

Scaling Factor The scaling factor

Attenuation Ratio (dB/km) The attenuation ratio

Gain The gain correction

Offset (K) The temperature offset
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Figure 15 Section Settings

6 Select Alarm and specify the settings as required. Refer to Table 6 on 
page 24. 

7 Select Alarm/Fire Classes and specify the settings as required. Refer to 
Table 7 on page 24. 

Table 6 Configuration Alarm Settings

Option Description

Enable Alarm Handling Flag to activate or deactivate alarms

Point of Return Destination where the fiber changes the 
direction back to the instrument.

Confirmation Cycles Number of alarm criteria repetitions 
before an alarm is raised

Reset Inputs Through the selected inputs the alarms 
are reset.

Table 7 Configuration Fire Class Settings

Option Description

Fire Class Definition Classes of fire where the fire sizes and 
the outputs that must be notified in case 
of individual fire class are defined.
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Figure 16 Configuration Alarm Settings

8 To modify the fire class settings, double-click an entry in the list. The 
Fire Class Collection Editor window opens. Specify properties of the 
selected fire class. Refer to Table 8 on page 25.

Figure 17 Fire Class Settings

9 Select Alarm/Zones and specify the settings as required. 

Table 8 Fire Class Settings

Option Description

Size The size of the fire

Outputs The output that is going to be notified in 
case of a fire of defined size
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10 Click Add. The Alarm Zone Editor window opens. Specify the settings 
in this window as required. Refer to Table 9 on page 26. 

Table 9 Configuration Alarm Zone Settings

Option Description

Alias The name of the zone

Start The zone start.

Span The length of the zone. Alarm Zones 
with Span = 0 are ignored when running 
a measurement.

Zone Type Zone types can be modified in the 
AlarmZoneTypes.txt file in the DTS 
Configurator folder. A new alarm type 
can also be added directly through GUI 
but will not be saved into the txt file for 
further use.

Maximum Check Checking of maximum temperature at 
any point in the zone area is either 
enabled (true) or disabled (false).

Maximum Value Maximum temperature that can be 
reached at any point of the zone before 
raising an alarm. The value is given in 
actual degrees (either C or F).

Minimum Check Checking of minimum temperature at 
any point in the zone area is either 
enabled (true) or disabled (false).

Minimum Value Minimum temperature that can be 
reached at any point of the zone before 
raising an alarm. The value is given in 
actual degrees (either C or F).

Positive Check Checking of maximum positive 
differentiation of temperature to zone 
average before raising an alarm is either 
enabled (true) or disabled (false).

Positive Difference (K) Maximum positive differentiation of 
temperature to zone average before 
raising an alarm. The value is given in 
kelvins.

Negative Check Checking of maximum negative 
differentiation of temperature to zone 
average before raising an alarm is either 
enabled (true) or disabled (false).

Negative Difference (K) Maximum negative differentiation of 
temperature to zone average before 
raising an alarm. The value is given in 
kelvins.
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Figure 18 Alarm Zone Settings

N O T E Fiber break can be detected only in zone area; if it is required to detect a fiber break outside of the 
standard alarm area you must set up a zone through out the entire fiber length.

11 Click OK to save the settings.
12 Select a zone from the table and click Clone to create another zone 

with the same characteristics. 
13 To modify the zone settings, double-click an entry and specify the 

settings in the Alarm Zone Editor window. Refer to Table 9 on page 26.
14 To delete a zone, select the zone from the list and click Remove. 
15 To change the order of zones select a zone and move it by clicking the 

arrows below the list.
16 Click OK to save all configuration settings.

G1/2/3 Check Checking of the G1/G2/G3 is either 
enabled (true) or disabled (false).

G1/2/3 Temperature (K) The temperature can rise or fall for the 
defined number of kelvins in a specified 
time before raising an alarm.

G1/2/3 Time (s) The temperature can rise or fall for the 
defined number of kelvins in a specified 
time before raising an alarm.

Outputs The outputs that will be notified about 
an alarm in the defined zone.

FiberBreak Outputs The outputs that will be notified in case 
of a fiber break in the selected zone.

Table 9 Configuration Alarm Zone Settings

Option Description
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Modifying a Configuration
To modify an existing configuration you first need to select it and then in 
the Edit menu click Configuration. The Configuration Editor dialog box 
opens, where you can modify the measurement, sensor, and alarm 
settings. Refer to chapter “Creating a New Configuration” on page 21.

N O T E The configuration files have the .cfg extension.

After changing the configuration attributes in the Configuration Editor edit 
dialog box, save your changes.

Copying a Configuration
To copy a configuration select the configuration you want to copy and 
perform one of the following:
• In the File menu select Save As. Specify a new name for the copy and 

click OK. The configuration is saved to the disk and renamed in the File 
Explorer pane. The original configuration is still stored on the disk.

• In the Edit menu select Clone Configuration. This option creates an 
exact copy of the currently selected configuration file.

Extracting a Configuration from a Trace
Trace files also contain the information about the configuration with 
which a measurement was initiated.

The DTS Configurator enables you to extract a configuration from a trace. 
This option creates a new Configuration file based on settings contained 
in a Trace file.

To extract a configuration, open the trace you want to use and in the Edit 
menu select Extract Configuration.
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Downloading Configurations
The application also enables you to download configurations from the 
DTS instrument. To download a configuration follow the procedure below:
1 In the Instrument menu select Download and Configurations. The 

Download Configurations dialog box opens.

Figure 19 Download Configurations

2 Click Download Configurations to start downloading configurations. 
You can monitor download progress and each downloaded 
configuration is added to the Configuration List.
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N O T E Invalid configurations will not be downloaded.

Figure 20 Save Downloaded Configurations

3 You can save downloaded configurations. Select the configurations 
you want to save by clicking the corresponding check-boxes.

4 Select the destination folder. You can save configurations to the default 
(predefined) folder, or select a different folder. 

5 In the Filename Prefix, enter the prefix for the filenames. You can also 
leave this field empty. All configurations are saved under the filename 
consisting of the prefix you entered and their original name.

6 Click Save Selected to save the configurations.

To exit the Download Configurations dialog box, click Close.
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Sequences

A sequence is a group of configurations that are a part of the same 
measurement process. When a sequence measurement is started 
measurements of all configuration in the list are triggered in the same 
order as the configurations are listed in the sequence.

Managing sequences involves the following:
• creating new sequences 

Refer to chapter “Creating a New Sequence” on page 31.
• adding configurations into a sequence 

Refer to chapter “Adding Configurations to a Sequence” on page 32
• modifying existing sequences 

Refer to chapter “Modifying a Sequence” on page 34.
• copying existing sequences 

Refer to chapter “Copying a Sequence” on page 34.

Creating a New Sequence
To create a new sequence of configurations, follow the procedure below:
1 In the File menu click New and select Sequence. A new sequence 

item is added in the File Explorer.
2 Select the new sequence and then in the Edit menu click Sequence. 

The Sequence Editor dialog box opens. The window opens also if you 
double-click the sequence or right-click it and select Edit.

3 Select General and specify the required settings. Refer to Table 10 on 
page 31.

4 Select Files and specify the configuration files that will be a part of the 
new sequence. Refer to Table 11 on page 32.

Table 10 The Sequence Settings

Option Description

Repeat Frequency of repeated sequence 
measurements. Each measurement 
cycle starts with the first configuration 
and ends with the last configuration in 
the sequence.
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Adding Configurations to a Sequence
To add a configuration to a sequence:
1 Open the File Explorer pane.
2 Click on a configuration and drag the configuration into a sequence. 

You can put up to four configurations into a sequence. 
N O T E Each added sequence receives a name prefix C1. If you add the same configuration twice the second 

added configuration will be renamed with prefix C2, C3, etc.

Dual-Ended Configuration Within a Sequence
One sequence can contain up to four configurations or up to two dual 
ended configurations. To define whether a configuration is dual-ended or 
not:
1 Double-click a sequence.
2 Select Files and check the dual-ended check box for the dual-ended 

configuration, meaning the dual-ended measurement is enabled. 

Possible combinations of configurations are:
• Up to four single-measurement configurations
• One dual-ended and up to two single-measurement configurations
• Two dual-ended configurations

Table 11 The Sequence Files

Option Description

Files The list of configuration files that are 
included into the sequence (see 
“Adding Configurations to a Sequence” 
on page 32).
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Figure 21 Dual-Ended Configurations

Modifying Configuration Within a Sequence
In the Sequence Editor window you can also edit configurations or 
remove them from a sequence. To modify a configuration:
1 Double-click a sequence.
2 Select Files and click Edit. See “Modifying a Configuration” on page 28 

for more details. 
3 Click OK to save the changes. 
4 When you change a configuration within a sequence you do not save 

the actual configuration but you need to save the sequence.
5 To rename a configuration within the sequence select the 

configuration, click the name of the configuration and insert new 
name.

6 To change the order of configurations click and drag aconfiguration 
into the desired position.

N O T E You can drag the configuration from a sequence into the Configurations folder where its name 
receives a prefix C1.
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Modifying a Sequence
To modify an existing sequence select it and then in the Edit menu click 
Sequence. The Sequence Editor dialog box opens, where you can modify 
the settings. Refer to chapter “Creating a New Sequence” on page 31.

N O T E The configuration files have the .seq extension.

After changing the sequence attributes in the Sequence Editor edit dialog 
box, save your changes.

Copying a Sequence
To copy a sequence select the sequence you want to copy and perform 
one of the following:
• In the File menu select Save As. Specify a new name for the copy and 

click OK. The sequence is saved to the disk and renamed in the File 
Explorer pane. The original sequence is still stored on the disk.

• In the Edit menu select Clone Sequence. This option creates an exact 
copy of the currently selected sequence file.
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Measurements

Managing measurements involves the following:
• starting measurements 

Refer to chapter “Starting a Single Measurement” on page 35.
• viewing and saving measurement traces 

Refer to chapter “Viewing a Running Measurement Trace” on page 36.

Starting a Single Measurement
You can start a single measurement with new or existing configurations.

N O T E If user authorization mode is set, you must be logged in before you can start a measurement.

To start a single measurement perform the following steps:
1 Create a new configuration or select an existing configuration.
2 In the Instrument menu click Start Measurement.

N O T E A measurement can be started only if the default DTS instrument is specified. Refer to chapter “DTS 
Instrument Discovery” on page 15.

When a measurement starts, a new item appears under Traces in the File 
Explorer pane, indicating a running measurement.

Once the application is started it starts to pick up the actual traces of a 
running measurement. The running measurement must be started 
previously by any user.

To stop the measurement click Stop Measurement in the Instrument 
menu.

When connected to the particular DTS instrument, all running 
measurements are monitored and visualized. In the following scenarios a 
new running trace is automatically created and the visualization begins as 
soon as the next trace data arrive:
1 The DTS instrument is measuring and the DTS Configurator has just 

been started.
2 The DTS Configurator is running and someone starts a measurement 

from another connection to the DTS instrument (DTS instruments 
support more than one connection, i.e. connection types).

Starting a Sequence Measurement
You can start a sequence measurement with new or existing 
configurations.
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N O T E If user authorization mode is set, you must be logged in before you can start a measurement.

To start a sequence measurement perform the following steps:
1 Create a new sequence or select an existing sequence (see “Creating 

a New Sequence” on page 31).
2 In the Instrument menu click Start Measurement. For each 

configuration of the sequence a trace graph will be displayed in the 
Data Visualization pane.

Viewing a Running Measurement Trace
While a measurement is in progress, you can view the measurement trace 
and measurement status.

In the Instrument pane you can track the progress of the measurement. 
The number of created traces and the status of the measurement are 
displayed.

Figure 22 Measurement Data in the Instrument pane

The Visualization pane enables you to:
• zoom in and out
• pan the view
• save picture
• send the graph to the printer

These options are available in the graph context menu. To access the 
context menu, right-click in the graph area.

To zoom in on a specific part of the graph, click and drag a rectangle in the 
area you want to view. To view markers on the zoomed-in part of the graph 
click the Center Markers icon. The markers will display on the graph only 
if the graph contains at least two intersection points.
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Figure 23 Zooming In

During a measurement you can define what kind of data you want to 
track.
1 Select a trace of a running measurement.
2 Select Temp, Loss, Alarm, and/or Zone to track selected data and 

display any of the selected status panes.
N O T E The type of data you defined in the Data Saved property in the Configuration settings (see “Creating 

a New Configuration” on page 21) is always tracked.

There are two types of traces:
• Intermediate trace is a trace that occurs during the measurement and 

is marked with red color. This measurement is not saved, it is 
displayed only as intermediate information. The interval for 
intermediate trace is set in the Configuration settings, under 
Measurement -> Update Time (see “Creating a New Configuration” 
on page 21).

• Measurement trace is a final trace, displayed when the measurement 
is finished. This measurement is marked with black color. The interval 
for measurement trace is set in the Configuration settings, under 
Measurement -> Time (min) and Time (s).

When a measurement finishes, you can save the measured results in the 
trace file. Select the finished trace in the Traces tree and in the File menu 
click Save.
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Traces

Managing traces involves the following:
• creating new traces 

Refer to chapter “Creating a New Trace” on page 38.
• viewing a trace 

Refer to chapter “Viewing a Trace” on page 38.
• copying existing traces 

Refer to chapter “Copying a Trace” on page 39.
• downloading traces 

Refer to chapter “Downloading Traces” on page 40.

Creating a New Trace
A new trace is automatically created with each new measurement. When 
a measurement starts, a new trace item is added in the Traces tree in the 
File Explorer pane. The newly created trace automatically inherits the 
configuration settings with which the measurement was started.

Viewing a Trace
To view a trace of a measurement:
1 In the File menu right-click a trace and select Show Graph. The 

measurement graph will open in the Data Visualization pane.
2 To view another trace of a measurement, repeat the above with 

another trace. Both graphs are now visible in the Data Visualization 
pane. You can simultaneously view up to 4 graphs.

N O T E If more than one graph window is open and you selected a full page view (by maximizing a graph 
window) select another open window by pressing ctrl + tab key.

Saving Multiple Traces
Manual saving of multiple traces is possible only when the following 
settings are set:
• In Settings -> Options go to Traces and leave the save multiple traces 

in single file check box unchecked.
• In Settings -> Options go to Traces/Auto Save and leave the enable 

check box unchecked.

To save multiple traces:
1 When a measurement is finished, click the Save button and Save 

Multiple Traces window appears.
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Figure 24 Save Multiple Traces

2 Select the folder or leave default folder, define the document prefix and 
according to which data the traces should be saved.

3 Click Save to save multiple traces.

Copying a Trace
To copy a trace, open the trace you want to copy and perform one of the 
following:
• In the File menu select Save As. Specify a new name for the copy and 

click OK. The trace is saved to the disk and renamed in the File 
Explorer pane.

• In the Edit menu select Clone Trace. This option creates an exact copy 
of the currently selected trace file.
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Downloading Traces
The application also enables you to download measurement traces from 
the DTS instrument. To download a trace follow the procedure below:
1 In the Instrument menu select Download and Traces. The Download 

Traces dialog box opens.

Figure 25 Download Traces

2 Click Download Traces to start downloading traces. You can monitor 
download progress and each downloaded trace is added to the Trace 
List.
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Figure 26 Save Downloaded Traces

3 You can save downloaded traces:
a Select the traces you want to save by clicking the corresponding 

check-boxes.
b Select the destination folder. You can save traces to default 

(predefined) folder, or select a different folder.
c In the Filename Prefix enter the prefix for the filenames. You can 

also leave this field empty. All traces are saved under the filename, 
consisting of the prefix you entered and their original name.

d Click Save Selected to save the traces.
4 To exit the Download Traces dialog box, click Close.
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Introduction

DTS Configurator features a multi-user management and login system.

The purpose of this feature is to provide a secure environment for 
instrument discovery, instrument modification, and for starting or stopping 
the measurements. Only registered users (users with a username and 
password) have access to these functionalities.



Users

DTS Configurator, Second edition, April 2007 45

Logging In

The application can run in two modes:
• anonymous mode
• user authorization mode

When you first install the application, there are no predefined users and 
the application will work in the anonymous mode (no authentication is 
required). 

As soon as the first user is configured, the application starts working in 
user authorization mode and authorization is required.

N O T E If you want to switch from user authentication mode back to anonymous mode, you have to delete 
all configured users.

In the user authorization mode you need to log in to perform the following 
actions:
• start a measurement
• stop a measurement
• configure the DTS instrument (perform DTS discovery, set instrument 

settings)

To log in, perform the following procedure:
1 In the Settings menu, select Login to open the Login dialog box or click 

the Login icon on the toolbar.
2 Enter your username and password and click OK.

N O T E If the Auto logout after x minutes checkbox is enabled, you will be automatically logged out when 
the specified time in minutes elapses.

Figure 27 Login Dialog Box

T i p : If you are not logged in and want to start or stop a measurement, or configure the DTS instrument, 
the Login dialog box opens automatically.



Users

46 DTS Configurator, Second edition, April 2007

Administering Users

All registered users can add, modify and delete other users.

For user administration perform the following:
1 In the Settings menu select Options to open the Program Options 

dialog box.
2 Select Users from the tree.

This dialog box enables you to:
• Add users 

Enter a new username and password, and reenter the password in the 
Confirm Password field. Click Add to save this user.

• Modify users 
You can only change the user password. In the list double-click the 
user you want to modify or insert username in the Username field, 
enter a new password and confirm password. Click Update.

• Delete users 
In the list select the user you want to delete and click Delete.

Figure 28 User Administration
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